Transform North America: Performance Degradation

Incident Report for Coalesce

Resolved

We increased resources to our database cluster to better handle customer workloads. This change was rolled out today at approximately 12:15PM Pacific and all operations have returned to normal.

We are adding additional monitoring & alerting to improve our response times if this situation occurs in the future.
Posted Jul 29, 2026 - 23:05 UTC

Monitoring

We have pushed out the change that should resolve this issue. Will monitor and close this out with more details when complete.
Posted Jul 29, 2026 - 19:53 UTC

Identified

We have identified the likely cause of a performance issue with Transform that is effecting overall operations. We will be pushing out a change here shortly to address this and will update this incident when complete.
Posted Jul 29, 2026 - 16:57 UTC
This incident affected: Transform (API, Scheduler, Web App).