We are continuing to monitor for any further issues.
Posted Aug 12, 2025 - 13:11 UTC
Monitoring
A fix has been implemented and available to all users. We will monitor and update when we are confident this is fully resolved.
Posted Aug 12, 2025 - 05:26 UTC
Identified
We are currently investigating and resolving an authentication issue affecting customers using Private Link with Snowflake OAuth. The issue is preventing successful authentication callbacks after users are redirected to Snowflake for single sign-on.
Following a recent update to improve OAuth redirect handling in Test Connections (release 7.22), we've identified an issue with how the system resolves Private Link DNS endpoints. This is resulting in authentication failures with the error: "Unable to process OAuth callback - getaddrinfo ENOTFOUND."
This issue is affecting:
Private Link customers using Snowflake OAuth for workspace authentication Users attempting to log into Snowflake via the UI with user credentials Refresh job executions initiated through Private Link URLs
Current Status Our engineering team has identified the issue and testing a fix. We are working to release an update to resolve the issue in the next 2-4 hours or less. If this time window changes, we will provide updates.
Posted Aug 12, 2025 - 03:33 UTC
This incident affected: API, Scheduler, and Web App.