Snowflake OAuth Workspace Authentication Errors: Request failed with status code 404

Incident Report for Coalesce

Resolved

The 404 errors are no longer occurring. Please reach out to Support if you experience any issues.
Posted Apr 29, 2025 - 19:01 UTC

Monitoring

We're currently monitoring an issue where some users are experiencing 404 error messages when authenticating to Snowflake via OAuth in the Coalesce user interface. Your data and configurations are safe and not affected by this authentication issue.

To quickly resolve this on your end:

1. Clear your browser cache:
- Chrome: Settings > Privacy and Security > Clear browsing data
- Firefox: Options > Privacy & Security > Cookies and Site Data > Clear Data
- Edge: Settings > Privacy, search, and services > Clear browsing data
- Safari: Preferences > Privacy > Manage Website Data > Remove All

2. Close and restart your browser completely

3. Log back into Coalesce and attempt to reconnect to Snowflake

This workaround has resolved the issue for our affected users. If you continue experiencing problems, please contact our Customer Support Team.
Posted Apr 29, 2025 - 16:46 UTC
This incident affected: [Azure] eastus2 (Web App, API, Scheduler), [Azure] westus2 (Web App, API, Scheduler), [AWS] us-east-1 (Web App, API, Scheduler), [AWS] us-west-2 (Web App, API, Scheduler), [Google] us-central1 (Web App, API, Scheduler), [Google] australia-southeast1 (Web App, API, Scheduler), [Google] europe-west3 (Web App, API, Scheduler), [Google] northamerica-northeast 1 (Web App, API, Scheduler), [AWS] us-east-2 (API, Scheduler, Web App), [Azure] southcentral (API, Web App, Scheduler), [AWS] eu-west-2 (API, Scheduler, Web App), and [Azure] centralus (Web App, API, Scheduler).