Transform North America: Job Execution Service Interruption

Incident Report for Coalesce

Resolved

The incident has been resolved.
Posted May 01, 2026 - 14:23 UTC

Monitoring

The hotfix has been delivered in version 7.33.2
Posted Apr 30, 2026 - 21:45 UTC

Identified

Coalesce Transform for customers in our North America region experienced a service degradation starting on Wednesday April 29th with the release of 7.33 that is affecting job execution.

- Root cause: A change in 7.33 made our node selector matching case-insensitive, which in a rare circumstance, made it possible for newly created jobs enter a recursive job-launch loop.
- Current state: We have applied a concurrency limit that prevents runaway job launches and are working on a hotfix to resolve the underlying issue.
- Fix inbound ASAP: Hotfix reverting selector matching to case-sensitive is approved and in our release pipeline now. We will update this incident once resolved.
Posted Apr 30, 2026 - 21:15 UTC
This incident affected: Transform - GCP (us-central1).