Transform Snowflake OAuth Errors

Incident Report for Coalesce

Resolved

This issue has been resolved.
Posted Sep 09, 2026 - 16:17 UTC

Monitoring

We have deployed a fix for anyone experiencing the following error when using OAuth with Snowflake:

"error":"Unable to process OAuth callback! error=RPError: iss mismatch, expected snowflake, got: https://example.snowflakecomputing.com/oauth","errorDetail":""

This change introduces case sensitivity for the configured Snowflake URL. If you continue to receive the above error and have a mixed-case URL, a workaround is to change the URL to all lowercase.
Posted Sep 09, 2026 - 03:35 UTC

Identified

Customers are experiencing OAuth authentication issues with Snowflake. We have identified the issue and are pushing out a fix.
Posted Sep 09, 2026 - 01:33 UTC
This incident affected: Transform (API, Scheduler, Web App).